View unanswered posts | View active topics It is currently 21 Aug 2018, 03:10



Reply to topic  [ 5 posts ] 
trying to install on debian ... 
Author Message

Joined: 12 Feb 2007, 11:10
Posts: 20
Post trying to install on debian ...
hi guys,
I'm trying to install the 3x configuration sofware on debian (Linux 64studio 2.6.21-1-multimedia-486 #1 SMP PREEMPT RT). When I run the binary I get this:

Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.6 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4),
and your program used 2.6 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.2,compatible with 2.4).

I have been through something like this before with ubuntu ...
http://www.waveidea.com/en/support/foru ... cb1e0a5eca

I figured these instructions might be out of date?...
Before I start this again, I noticed there is an option to use to use X11 instead of GTK. I tried this but got a configure error:
configure: error: X11 not found.
I have installed the X client dev package from apt-get but I'm uncertain as to what this paramater is local for. Is it the headers or a libaray. the name would suggest the latter.

I am running configure like so:
./configure --with-x11 --libdir=/usr/lib --enable-unicode --enable-compat22

I have tried loads of combinations for libdir but to no avail. where should libdir point to?
Somewhere with *.a.so or .*.a or a a folder full of headers

any chance I can compile the tool from source, that would tidy all of this?

Best regards,
Conor


27 Apr 2008, 03:20
Profile

Joined: 12 Feb 2007, 11:10
Posts: 20
Post resolution
okay finally had some time to figure this out.
basically easiest approach.

-Install libgtk2.0-dev from apt-get (enable respective repos if apt cannot find it and apt-get update)
-download wxgtk2.4 (http://www.wxwidgets.org/downloads/)
-configure with
./configure --with-gtk --libdir=/usr/lib --enable-unicode --enable-compat22
make
make install


The bitstream software should then start without whinging about wxgtk library mismatches.

cj


09 May 2008, 17:39
Profile

Joined: 12 Feb 2007, 11:10
Posts: 20
Post 
actually it would seem you only need to compile 2.6.4. Compiling 2.4 should seem pointless as 2.6.4 supports backward compatibility with 2.2 which annoyingly the bitstream binary demands :{ But the app crashes when I tried to run against 2.6.4 compiled with compatibiltiy for 2.2 hence why I used 2.4. This is very frustrating as ubuntu are now 2.8. Please bitstream recompile and remove this silly dependency. Right now I cannot run Sooperlooper and the bitstream config software on the same distrubution because of this !!!
arg!


12 Jul 2008, 14:18
Profile

Joined: 12 Feb 2007, 11:10
Posts: 20
Post Exception when running against 2.6.4
2.6.4 compiled with compatibilty for 2.2.

*** glibc detected *** ./config_soft_v14: munmap_chunk(): invalid pointer: 0x083cc720 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6(cfree+0x1bb)[0xb759761b]
/usr/lib/libglib-2.0.so.0(g_free+0x31)[0xb6fe38b1]
/usr/lib/libwx_gtk2u_core-2.6.so.0[0xb7b63c70]
/usr/lib/libwx_gtk2u_core-2.6.so.0(_ZN8wxButton10SetDefaultEv+0x76)[0xb7b63d66]
./config_soft_v14[0x806cb76]
./config_soft_v14[0x80905a6]
./config_soft_v14[0x8090667]
./config_soft_v14[0x809f679]
./config_soft_v14(_ZN12wxAppConsole10CallOnInitEv+0x18)[0x80a0880]
/usr/lib/libwx_baseu-2.6.so.0(_Z7wxEntryRiPPw+0x40)[0xb78f0ff0]
/usr/lib/libwx_baseu-2.6.so.0(_Z7wxEntryRiPPc+0x50)[0xb78f10f0]
./config_soft_v14[0x80a0632]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0)[0xb753e450]
./config_soft_v14(__gxx_personality_v0+0x1e1)[0x8056731]
======= Memory map: ========
08048000-08203000 r-xp 00000000 08:02 8110083 /home/ronoc/Desktop/bs3x_config_soft_v14_fc5_beta/config_soft_v14
08203000-0820c000 rw-p 001bb000 08:02 8110083 /home/ronoc/Desktop/bs3x_config_soft_v14_fc5_beta/config_soft_v14
0820c000-0862f000 rw-p 0820c000 00:00 0 [heap]
b6732000-b6736000 r-xp 00000000 08:02 3147069 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
b6736000-b6737000 rw-p 00003000 08:02 3147069 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
b6738000-b68de000 r--p 00000000 08:02 3147903 /usr/share/icons/hicolor/icon-theme.cache
b68de000-b693e000 rw-s 00000000 00:09 2949144 /SYSV00000000 (deleted)
b693e000-b6944000 r-xp 00000000 08:02 3148195 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so
b6944000-b6945000 rw-p 00005000 08:02 3148195 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so
b6945000-b6a49000 rw-p b6945000 00:00 0
b6a49000-b6ada000 r--p 00000000 08:02 3531355 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf
b6ada000-b6adc000 r-xp 00000000 08:02 3146973 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b6adc000-b6add000 rw-p 00001000 08:02 3146973 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b6add000-b6ade000 r--p 00000000 08:02 3137830 /usr/share/locale-langpack/en_GB/LC_MESSAGES/glib20.mo
b6ade000-b6ae4000 r--s 00000000 08:02 6580013 /var/cache/fontconfig/945677eb7aeaf62f1d50efc3fb3ec7d8-x86.cache-2
b6ae4000-b6ae7000 r--s 00000000 08:02 6580799 /var/cache/fontconfig/e383d7ea5fbe662a33d9b44caf393297-x86.cache-2
b6ae7000-b6ae8000 r--s 00000000 08:02 6580795 /var/cache/fontconfig/c69f04ab05004e31a6d5e715764f16d8-x86.cache-2
b6ae8000-b6ae9000 r--s 00000000 08:02 6580786 /var/cache/fontconfig/4c73fe0c47614734b17d736dbde7580a-x86.cache-2
b6ae9000-b6aec000 r--s 00000000 08:02 6580778 /var/cache/fontconfig/a755afe4a08bf5b97852ceb7400b47bc-x86.cache-2
b6aec000-b6aef000 r--s 00000000 08:02 6580014 /var/cache/fontconfig/6d41288fd70b0be22e8c3a91e032eec0-x86.cache-2
b6aef000-b6af2000 r--s 00000000 08:02 6580770 /var/cache/fontconfig/de156ccd2eddbdc19d37a45b8b2aac9c-x86.cache-2
b6af2000-b6afa000 r--s 00000000 08:02 6580763 /var/cache/fontconfig/e3de0de479f42330eadf588a55fb5bf4-x86.cache-2
b6afa000-b6b02000 r--s 00000000 08:02 6580749 /var/cache/fontconfig/0f34bcd4b6ee430af32735b75db7f02b-x86.cache-2
b6b02000-b6b05000 r--s 00000000 08:02 6580282 /var/cache/fontconfig/de9486f0b47a4d768a594cb4198cb1c6-x86.cache-2
b6b05000-b6b0c000 r--s 00000000 08:02 6580747 /var/cache/fontconfig/d52a8644073d54c13679302ca1180695-x86.cache-2
b6b0c000-b6b12000 r--s 00000000 08:02 6580683 /var/cache/fontconfig/089dead882dea3570ffc31a9898cfb69-x86.cache-2
b6b12000-b6b1b000 r-xp 00000000 08:02 4260005 /lib/tls/i686/cmov/libnss_files-2.7.so
b6b1b000-b6b1d000 rw-p 00008000 08:02 4260005 /lib/tls/i686/cmov/libnss_files-2.7.so
b6b1d000-b6b25000 r-xp 00000000 08:02 4260007 /lib/tls/i686/cmov/libnss_nis-2.7.so
b6b25000-b6b27000 rw-p 00007000 08:02 4260007 /lib/tls/i686/cmov/libnss_nis-2.7.so
b6b27000-b6b3b000 r-xp 00000000 08:02 4260001 /lib/tls/i686/cmov/libnsl-2.7.so
b6b3b000-b6b3d000 rw-p 00013000 08:02 4260001 /lib/tls/i686/cmov/libnsl-2.7.so
b6b3d000-b6b3f000 rw-p b6b3d000 00:00 0
b6b3f000-b6b46000 r-xp 00000000 08:02 4260002 /lib/tls/i686/cmov/libnss_compat-2.7.so
b6b46000-b6b48000 rw-p 00006000 08:02 4260002 /lib/tls/i686/cmov/libnss_compat-2.7.so
b6b48000-b6b4a000 r--s 00000000 08:02 6581056 /var/cache/fontconfig/e13b20fdb08344e0e664864cc2ede53d-x86.cache-2
b6b4a000-b6b56000 r-xp 00000000 08:02 3148094 /usr/lib/gtk-2.0/2.10.0/engines/libindustrial.so
b6b56000-b6b57000 rw-p 0000c000 08:02 3148094 /usr/lib/gtk-2.0/2.10.0/engines/libindustrial.so
b6b57000-b6b5a000 r--p 00000000 08:02 3137823 /usr/share/locale-langpack/en_GB/LC_MESSAGES/gtk2Aborted
ronoc@ubuntu:~/Desktop/bs3x_config_soft_v14_fc5_beta$


12 Jul 2008, 14:40
Profile

Joined: 12 Feb 2007, 11:10
Posts: 20
Post any progress on this
Any chance you the linux binaries being recompiled for wxgtk greater than 2.4. It would take an hour tops to sort this out. Please !!!


26 Feb 2009, 15:59
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software